关灯
开启左侧

【原创】gulp v4.0.0必须要注意的语法

[复制链接]
老蚊子 发表于 2018-12-20 08:35:00 | 显示全部楼层 |阅读模式 打印 上一主题 下一主题
 
昨天npm i install gulp -D后,发现gulp 4.0版本啦。现在安装gulp,也可以使用npm i install gulp-cli -g实现全局安装,npm i install gulp -D实现开发依赖。总之不指定版本时,默认是v4.0.0啦。
相比gulp3.x版本,语法有比较明显的变化,特别是依赖注入这块,不是以前的语法!


原来的语法:
  1. gulp.task('html',function(){
  2. // 做一些事件
  3. })
  4. //依赖
  5. gulp.task('default',['html'], function((){
  6. //做一些事件
  7. })
复制代码
现在的语法 :
gulp.task('任务名', 函数); 不再支持依赖的数组了。也就是task只有两个参数可用。

  1. var  html = ()=>{
  2. return gulp.src()
  3.         .pipe(gulp.dest()
  4. }

  5. gulp.task('default', html)
复制代码
如果要实现依赖怎么办呢?
  1. var  html = ()=>{
  2. return gulp.src()
  3.         .pipe(gulp.dest()
  4. }
  5. var css = ()=>{
  6. return gulp.src()
  7.         .pipe(gulp.dest()
  8. }
  9. var js = ()=>{
  10. return gulp.src()
  11.         .pipe(gulp.dest()
  12. }
  13. var build = gulp.series(html,css,js)  //串行执行,即同步
  14. // var build = gulp.parallel(html,css,js) //并行执行,即异步

  15. gulp.task('default', build)  //依赖实现
复制代码




 
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则


1关注

13粉丝

75帖子

排行榜
关闭

站长推荐上一条 /1 下一条

官方微信

全国服务热线:

400-9988-316

公司地址:国家西部信息安全产业基地(成都市高新区云华路333号)

邮编:610000    Email:2908503813@qq.com

Copyright   ©2015-2016  EOIT论坛Powered by©Discuz!    ( 蜀ICP备11000634号-7 )